I recently order OS X MTN LION and I tried to download to new OS X i brought and a message said that it wasn't compatible with my computer?

Hello, I recently order OS X MTN LION and I tried to download to new OS X i brought and a message said that it wasn't compatible with my computer?

I have a mini mac with 4 G of memory, 75 G of space available and I'm running the latest version of Snow Leopard 10.6.8 on my computer.

Is there something else I'm missing? Do I need to upgrade my version to 10.7?

Thank you...

<Re-Titled by Host>

Has invited:

howapple - hello

Favor from:

A 2007 Mac mini isn't capable of running Mountain Lion. If you don't have a Mac which can, ask Apple for a refund.

(141807)

To reply to a question, please Login or registered