Dock keeps reseting to its default settings. How do I get it to stop doing that?

I've been having this problem since yesterday. Yesterday, I uninstalled Norton Internet Security ( ) so I can install Norton Security ( ) for my MacBook Pro (15 inch, Mid 2012, Non-Retina, Runs on OS X 10.8.5). After I uninstalled Norton IS, I was prompted to reset my machine and reset it I did. After I turned it back on, I noticed that the dock was set back to its original settings. The dock was not on the left side of the screen at all. (That's my preferred dock position.) Instead, it was moved to the bottom of the screen. Not only that, all of the app icons that were not originally in the dock have been removed. (i.e. TextEdit, Preview, Google Chrome, etc.) After I finished installing Norton Security, I had to manually restore the dock to my preferred settings. After the restoration, I was hoping that this problem would never occur again. Later I opened Norton Security to use the LiveUpdate feature and after I used that feature, I was prompted to reset my MBP. I did that and by the time it turned back on, the dock was set back to its original settings again. After I noticed that, I had to preform the manual restoration again. Later that night, I had to shut down my MBP and I was dreading that the dock problem would occur again by the time that I turn my MBP on. Earlier today, I turned it back on and the dock problem did occur again. Once again, I had to do the manual restoration.

I never had this problem from before. Has anyone has had this problem from before? Does anyone know how to fix this? How do I keep my customized dock setting intact every time I reset/turn on my MBP?

Has invited:

howapple - hello

Favor from:

No problem bringing the thread back. If you don't get more answers, just make a post like Bump. If you keep the thread near the top, it will get looked at more.

Might be a corrupt .plist.

Do a backup, preferably 2 backups on 2 separate drives.

Quit the application.

In Finder hold down the option/alt key while selecting the Go menu item. Select Library. Then go to Preferences/ Move the .plist to your desktop.

Restart the computer, open the application and test. If it works okay, delete the plist from the desktop.

If the application is the same, return the .plist to where you got it from, overwriting the newer ones.

If you want to make your user library permanently visible, run the below command in Applications/Utilities/Terminal.

chflags nohidden ~/Library/

You will need to do that after any updates.

To reply to a question, please Login or registered