How do I sync my Messages between my Mac, iPhone, and my iPad?

Basically, I cant figure out how to get them all in sync. Conversations that I have on my Mac do not show up on my iPhone and vice versa.

Has invited:

howapple - hello

Favor from:

This can be a bit tricky to set up, but it is possible.

in Messages (OS X):

1. Launch Messages and open Prefs > Accounts.

2. Make sure you are logged in with the AppleID you are using all your devices.

3. Set caller ID to this email address/AppleID.

iPad:

1. Go to Settings > Messages.

2. Make sure iMessage is set to ON.

3. Tap "receive at" and make sure you are logged in with the same AppleID you are using on your Mac.

4. Tap "caller ID" and make sure that email address/AppleID is selected.

iPhone:

1. Go to Settings > Messages.

2. Make sure iMessage and Send as SMS are both set to ON.

3. Tap "recieve at" and make sure you are logged into the same AppleID as on your Mac and iPad.

4. Tap "caller ID" and make sure that email address/AppleID is selected.

Going forward, when anyone on an IOS device sends you a Message they need to send it to your AppleID/email address, NOT your phone number. In this way all messages will be in sync across all devices.

To reply to a question, please Login or registered