Which iPods are compatible with the latest iTunes?

I need to buy an iPod but can't afford a new one, so I'll get a second hand one.  It's imperative that the latest version of iTunes is compatible with the iPod that I get. 

 

I've read that certain older iPods are not compatible and would like to know from which model onwards I'll be able to install the latest iTunes.

 

Many thanks


iMac, macOS High Sierra (10.13.1)
Has invited:

howapple - hello

Favor from:


For Apple Music the following are supported:

 

  • iTunes 12.2 or better on Mac or Windows
  • iPhone 4s or later
  • iPad 2 & iPad mini or later
  • iPod touch 5th generation or later

 

tt2

To reply to a question, please Login or registered