Seeing meetings created in Apple Watch

When I create a meeting using Siri through my Apple Watch I can't see it on my iPhone.

Has invited:

admin

Favor from:

The following steps may also help (follow them in order):

  • On your iPhone, in the Contacts app:
    • Check that your contact card contains your name, Apple ID email address and phone number.
  • On your iPhone, go to: Settings > Mail, Contacts, Calendars > in the Contacts section, check that My Info is using your contact card.
  • On your iPhone, go to: Settings > General > Siri > My Info - check that your contact card is selected.
  • Check also that iCloud is enabled for Contacts:
    • On your iPhone, go to: Settings > iCloud - turn on Contacts.
  • On your iPhone, in the Watch app, go to: My Watch > General > Reset > tap on Reset Sync Data.
    • Nothing will seem to happen, but the process will run in the background / invisibly to the user, so allow a minute or so.
  • It may then also help to restart both your iPhone and your watch. Turn both devices off together, then restart your iPhone first:
    • To turn your watch off: press and hold the side button until you see the Power Off slider; drag the slider to turn off.
    • To turn it back on: press and hold the side button until you see the logo.
  • Disable and re-enable Siri:
    • On your iPhone, go to: Settings > General > Siri - turn off, pause for a few moments, then turn Siri back on.

To reply to a question, please Login or registered