CommCenter wants to use the "Local Items" keychain.

Every time I turn on my iMac, I get this message:

Screen Shot 2016-05-24 at 14.54.17.png

Typing in my keychain password makes it go away, but the next time I reboot and log in the message reappears.

If I log out and log back in without rebooting, the message doesn't appear.

I have been having this problem since I changed my Apple ID password.

Has invited:

howapple - hello

Favor from:

Please take each of the following steps that you haven't already tried, testing after each one. Back up all data before making any changes.

Step 1

Open the iCloud preference pane and uncheck the Keychain box. You'll be prompted to delete the local iCloud keychain. Confirm. Then re-check the box. Follow one of the procedures described in this support article to set up iCloud Keychain on an additional device.

Step 2

Triple-click the line below on this page to select it, then copy the text to the Clipboard by pressing the key combination command-C:


In the Finder, select

Go Go to Folder...

from the menu bar and paste into the box that opens by pressing command-V. You may not see what you pasted because a line break is included. Press return. A folder named "Keychains" should open. There should be a file in that folder with the name "login.keychain". If there is also a file iwith the name "login_renamed_1.keychain", then please do as follows:

☞ Rename login.keychain to "login-old.keychain".

☞ Rename login_renamed_1.keychain to "login.keychain".

You can then close the folder.

Delete the login keychain from the keychain list in Keychain Access. Choose

Delete References

when prompted, not Delete References & Files.


File Add Keychain...

from the menu bar. Add back the file now named "login.keychain". If any of your needed keychain items are missing from it, also add back the file now named "login-old.keychain". I suggest you transfer any needed items from that keychain to the login keychain, then delete it. The transfers are made by drag-and-drop in Keychain Access. You'll need to enter your password for each item transferred.

Quit Keychain Access.

Step 3

If you still have problems, uncheck the Keychain box again in the iCloud preference pane and continue.

Inside the Keychains folder that you opened in Step 2 is a subfolder with a long name similar to (but not the same as) this:


The above is only an example; yours will have a different name of the same general form. Drag the subfolder (not the Keychains folder) to the Trash.

Restart the computer, empty the Trash, and re-enable iCloud Keychain.

To reply to a question, please Login or registered