which itunes version is compatible with ipod touch 3.1.3 version

The updated itunes is not compatible with my ipod as i've been told it is now obsolete

Could someone advise me which version of itunes I can download so i'll be able to use again please

My ipod is version 3.1.3 and i've been told it's from 2009 (immaculate condition so I don't want to buy a new one)

Has invited:

howapple - hello

Favor from:

For general advice see Troubleshooting issues with iTunes for Windows updates.


The steps in the second box are a guide to removing everything related to iTunes and then rebuilding it which is often a good starting point unless the symptoms indicate a more specific approach.

Review the other boxes and the list of support documents further down the page in case one of them applies.

The further information area has direct links to the current and recent builds in case you have problems downloading, need to revert to an older version or want to try the iTunes for Windows (64-bit - for older video cards) release as a workaround for installation or performance issues, or compatibility with third party software.

Your library and device backups should be unaffected by these steps but there are links to backup and recovery advice should it be needed.



tt2

To reply to a question, please Login or registered